Logo

Blog o JavaScript, jQuery, HTML5, CSS3 i 4. Porady jak pisać dobrej jakości kod, tutoriale, nowości.

19 listopada Google Maps API 2 zostanie wyłączone!

Mam nadzieję, że pamiętacie by zmienić silnik Google Maps z wersji 2 na 3. Google wysyłało specjalne powiadomienia dla webmasterów o tym fakcie.

Jeżeli posiadasz serwis na którym używasz Google Maps z API w wersji 2 i nie dostałeś stosownego powiadomienia, to masz problem. 19 listopada tego roku Google zamyka API w wersji 2. To i tak o 6 miesięcy później niż pierwsza planowana data czyli 19 maja 2013. Webmasterzy potrzebiwali więcej czasu by przesiąść na nowszą wersję.

Takie powiadomienia dostawali webmasterzy, którzy mają dodany serwis do Google Webmaster Tools i korzysta z Google Maps API.

Jeżeli nie uda Ci się zmienić wersji API, to mapki przestaną działać. Tak więc jeżeli masz "mapkę dojazdu" na swojej stronie firmowej, to możesz stracić potencjalnych klientów :P.

Though we expect this wrapper to work for most simple maps, we cannot guarantee that your maps will continue to function. We therefore highly recommend that you migrate to v3 before November 19. The good news is that Google Maps JavaScript API v3 is more robust and feature rich than v2, and we’ve written a guide to assist the migration.

Nie powinno być problemów podczas migracji przy prostych mapkach, jednak mimo wszystko warto przesiąść się na nowszą wersję by nie było potem niespodzianek.

Skoro jesteśmy już przy mapkach Google, to zapraszam do lektury mojego gościnego wpisu na webhelp o kolorowaniu mapek.

Autor wpisu

Piotr cichosz (shpyo) — Front-end developer Twórca kilku serwisów internetowych oraz autor kilku blogów. Pasjonat nowych, otwartych technologii.

Komentarze

Gavatar Piotr

13.11.2013 Piotr

Właśnie zmieniam te mapki od paru dni, bo widać żarty się skończyły.
ps. błąd masz w tekście "planowana data czyli 19 maja 2012" powinno być chyba 19 maja 2013 :)

Dodaj komentarz